OSPF

 

 

Router0

Router(config)#router ospf 7  //숫자 아무거나줘도됨

Router(config-router)#network 192.168.70.0 0.0.0.255 area 0

//area 맞춰야한다.

Router(config-router)#network 1.1.70.0 0.0.0.255 area 0

Router1

Router(config)#router ospf 8  //숫자 아무거나줘도됨

Router(config-router)#network 192.168.80.0 0.0.0.255 area 0

//area 맞춰야한다.

Router(config-router)#network 1.1.70.0 0.0.0.255 area 0

 

 

area  2개이상 나누기

 

//핑크선 기준으로 단절된 네트워크 형성

 

Router0

Router(config-if)#router ospf 7

Router(config-router)#net 192.168.10.0 0.0.0.255 area 0

Router(config-router)#net 1.1.12.0 0.0.0.255 area 0

 

Router1

Router(config-if)#router ospf 7

 

Router(config-router)#net 1.1.12.0 0.0.0.255 area 0

Router(config-router)#net 1.1.23.0 0.0.0.255 area 1

Router2

Router(config-if)#router ospf 7

 

Router(config-router)#net 1.1.34.0 0.0.0.255 area 2

Router(config-router)#net 1.1.23.0 0.0.0.255 area 1

 

 

Router3

Router(config-if)#router ospf 7

 

Router(config-router)#net 1.1.34.0 0.0.0.255 area 2

Router(config-router)#net 192.168.20.0 0.0.0.255 area 2

 

loop를 통해 단절 네트워크 연결

// Area 0 : 백본 에어리어 Area2 : 단절 에어리어

// Area 1 : 경유 에어리어

 

 

1. Router1 lo0 : 2.2.2.2

Router(config)#interface loopback 0

Router(config-if)#ip address 2.2.2.2 255.255.255.0

//reboot해야 설정됨

Router(config-router)#area 1 virutal-link 3.3.3.3

//상대방 루프번호

2. Router2 lo0 : 3.3.3.3

Router(config)#interface loopback 0

Router(config-if)#ip address 3.3.3.3 255.255.255.0

//reboot해야 설정됨

Router(config-router)#area 1 virutal-link 2.2.2.2

//상대방 루프번호

'Network Security' 카테고리의 다른 글

스캐닝  (0) 2019.01.30
ACL(접근 통제 목록)  (0) 2019.01.29
redistribute(재분배)  (0) 2019.01.28
eigrp  (0) 2019.01.28
RIP  (0) 2019.01.28

redistribute(재분배)

// 다른 프로토콜을 재분배하여 연결해준다

 

Router5  //가운데 라우터기준으로 왼쪽은 RIPV2 오른쪽은 EIGRP

[EIGRP -> RIP]

Router(config-router)#router eigrp 7

Router(config-router)#redistribute rip metric 1544 20000 255 1 1500                       //Bandwidth , 딜레이 ,신뢰도 ,로딩,MTU

[RIP -> EIGRP]

Router(config-router)#router rip

Router(config-router)#ve 2

Router(config-router)#redistribute eigrp 7 metric 1

 

 

[EIGRP -> OSPF]

Router(config-if)#router eigrp 7

 

 

Router(config-router)#redistribute ospf 7 metric 1544 20000 255 1 1500

[OSPF -> EIGRP]

Router(config-router)#router ospf 7

 

 

Router(config-router)#redistribute eigrp 7 subnets

 

 

 

 


 

 


 

 


 

 

 

 

'Network Security' 카테고리의 다른 글

ACL(접근 통제 목록)  (0) 2019.01.29
OSPF  (0) 2019.01.28
eigrp  (0) 2019.01.28
RIP  (0) 2019.01.28
라우팅  (0) 2019.01.25

eigrp

 

 

 

Router0

Router(config)#router eigrp 7  //숫자가 양쪽 라우터 같아야함

Router(config-router)#network 1.1.45.0

Router(config-router)#network 192.168.40.0

Router(config-router)#no auto-summary

 

Router1

Router(config)#router eigrp 7

Router(config-router)#network 1.1.45.0

Router(config-router)#

%DUAL-5-NBRCHANGE: IP-EIGRP 7: Neighbor 1.1.45.1 (Serial0/0/0) is up: new adjacency            //설정이 잘 됐다는 것

Router(config-router)#network 192.168.50.0

Router(config-router)#no auto-summary

eigrp2 //2번째방법

 

Router(config)#router eigrp 7  //숫자가 양쪽 라우터 같아야함

Router(config-router)#network 1.1.45.1 0.0.0.0

Router(config-router)#network 192.168.40.1 0.0.0.0

Router(config-router)#no auto-summary

'Network Security' 카테고리의 다른 글

OSPF  (0) 2019.01.28
redistribute(재분배)  (0) 2019.01.28
RIP  (0) 2019.01.28
라우팅  (0) 2019.01.25
frame-relay  (0) 2019.01.24

 

 

 

 

RIP v2

 

Router0

Router(config)#router rip

Router(config-router)#version 2

Router(config-router)#network 1.1.12.0    

Router(config-router)#network 192.168.10.0

 //네트워크주소 2개를 라우터에게알려줌

Router(config-router)#no auto-summary 

 //축약하지 말라는 뜻(Distance는 다 줘야함)

Router1

Router(config)#router rip

Router(config-router)#version 2

Router(config-router)#network 1.1.12.0

Router(config-router)#network 192.168.20.0

Router(config-router)#no auto-summary

 

 

 






'Network Security' 카테고리의 다른 글

redistribute(재분배)  (0) 2019.01.28
eigrp  (0) 2019.01.28
라우팅  (0) 2019.01.25
frame-relay  (0) 2019.01.24
PPP인증  (0) 2019.01.24

 

라우팅

- 해당 네트워크가 모르는 작업을 알려주는 것

 

라우터는  Static 과 Dynamic으로 나뉜다.

 

[Static]

 - 네트워크 관리자가 직접 설정

 - Dynamic보다 빠르다.

 - 단일 경로 일때 사용하면 효율적

 

[설정]

 

Router0

 Router(config)#ip route 192.168.20.0 255.255.255.0 1.1.12.2

 Router(config)#ip route 192.168.30.0 255.255.255.0 1.1.12.2

//192.168.20.0 네트워크로 보낸다 1.1.12.2를통해 

   ip주소대신 보내려는 라우터의 포트번호를 입력해도 됨.

Router1

Router(config)#ip route 192.168.10.0 255.255.255.0 1.1.12.1

Router(config)#ip route 192.168.30.0 255.255.255.0 1.1.23.1

Router2

Router(config)#ip route 192.168.10.0 255.255.255.0 1.1.23.2

Router(config)#ip route 192.168.20.0 255.255.255.0 1.1.23.2



 

  

[Dynamic]

 - 라우팅 프로토콜

   : 라우팅 정보를 수집하여 상대측에게 보내주는 역할

 - 라우팅 프로토콜은 Distance Vector와 Link state로 나뉜다.

 - 속도가 느리다.

 - 경로가 2개이상 일때 사용하면 효율적

 

 Distance Vetcor : RIPv1,v2,IGRP,EIGRP,BGP  //IGP  EGP

 Link state : OSPF , ISIS

 

 

Classful : RIPv1,IGRP

classless : RIPv2,EIGRP,IGRP       //IGRP,EGRP : CIDR

 

RIP : 벨만-포트 알고리즘

 

OSPF : 다익스트라 알고리즘

 

IGRP : DUAC

'Network Security' 카테고리의 다른 글

eigrp  (0) 2019.01.28
RIP  (0) 2019.01.28
frame-relay  (0) 2019.01.24
PPP인증  (0) 2019.01.24
NAT  (0) 2019.01.23

frame-relay

- ATM의 단점인 속도가 느린 것을 보안하기 위해 나온 프로토콜

- 처음 받은 라우터가 1번만 체크하고, 나머지 라우터는 그냥 보내고,

  마지막 라우터가 한번 더 체크한다.

- 즉, 매번 체크하여 신뢰성은 좋지만, 속도가느린 ATM의 단점을 보안

  하기 위하여 나온 방식이다.

- Point to Point 방식과 Multi Point 방식으로 나뉜다.

- frame relay 스위치가 필수적이다. 없으면 통신 안됨.

 

 

 

[Point to Point]

- 서브 인터페이스를 만들어 연결

- DLCI : 라우터 끼리 통신할 때 나타내는 식별자

 

[설정]

 

Router 0

1. Router(config)#int s0/0/0

2. Router(config-if)#encapsulation frame-relay

3. Router(config-if)#int s0/0/0.102 point

4. Router(config-subif)#ip address 10.10.10.1 255.255.255.0

5. Router(config-subif)#frame-relay interface-dlci 102

6. Router(config-if)#int s0/0/0.103 point

7. Router(config-subif)#ip address 30.30.30.1 255.255.255.0

8. Router(config-subif)#frame-relay interface-dlci 103

Router 1

1. Router(config)#int s0/0/0

2. Router(config-if)#encapsulation frame-relay

3. Router(config-if)#int s0/0/0.201 point

4. Router(config-subif)#ip address 10.10.10.1 255.255.255.0

5. Router(config-subif)#frame-relay interface-dlci 201

6. Router(config-if)#int s0/0/0.203 point

7. Router(config-subif)#ip address 20.20.20.1 255.255.255.0

8. Router(config-subif)#frame-relay interface-dlci 203

 

Router 2

1. Router(config)#int s0/0/0

2. Router(config-if)#encapsulation frame-relay

3. Router(config-if)#int s0/0/0.301 point

4. Router(config-subif)#ip address 30.30.30.2 255.255.255.0

5. Router(config-subif)#frame-relay interface-dlci 301

6. Router(config-if)#int s0/0/0.302 point

7. Router(config-subif)#ip address 20.20.20.2 255.255.255.0

8. Router(config-subif)#frame-relay interface-dlci 302

 

Cloud0

//아까 설정한 DLCI들을 직접매핑해준다.

Serial0

 

Serial1

 

Serial2

 

 frame-relay

 

 

 

[Multi Point]

 

- 하나의 인터페이스로 여러개의 호스트를 액세스한다.

-

 

[설정]

Router0

1. Router(config)#int s0/0/0

2. Router(config-if)#ip address 10.10.10.1 255.255.255.0

3. Router(config-if)#encapsulation frame-relay

4. Router(config-if)#frame-relay map ip 10.10.10.2 102 broadcast

5. Router(config-if)#frame-relay map ip 10.10.10.3 102 broadcast

Router2

1. Router(config)#int s0/0/0

2. Router(config-if)#ip address 10.10.10.3 255.255.255.0

3. Router(config-if)#encapsulation frame-relay

4. Router(config-if)#frame-relay map ip 10.10.10.2 302 broadcast

5. Router(config-if)#frame-relay map ip 10.10.10.3 302 broadcast

Router1

1. Router(config)#int s0/0/0

2. Router(config-if)#encapsulation frame-relay

3. Router(config-if)#int se0/0/0.123 mul

4. Router(config-subif)#ip address 10.10.10.2 255.255.255.0

5. Router(config-subif)#fr map ip 10.10.10.1 201 broadcast

 

6. Router(config-subif)#fr map ip 10.10.10.3 203 broadcast

Cloud0

 

 

 

 

 

Serial0

 

 

 

Serial1

 

 

 

Serial2

frame-relay

 

 

 

 

멀티포인트에 RIP프로토콜을 주어 통신

split-horizon을 비활성해야 통신이 가능하다.

멀티포인트에 OSPF프로토콜을 주어 통신

 

중계라우터의 Pri 값을 높게 설정해주어야함

위의 그림에서 중계라우터는 Router8

show ip ospf neighbor //누가 우선순위인지 확인

1.ospf 설정

Router6

Router(config)#router ospf 7

Router(config-router)#net 192.168.10.0 0.0.0.255 area 0

Router(config-router)#net 1.1.123.0 0.0.0.255 area 0

Router(config)#int s0/0/0  //시리얼 포트로 들어가서

Router(config-if)#ip ospf network broadcast

 // 브로드캐스트를 해야됨

Router7

Router(config)#router ospf 7

Router(config-router)#net 192.168.20.0 0.0.0.255 area 0

Router(config-router)#net 1.1.123.0 0.0.0.255 area 0

Router(config)#int s0/0/0  //시리얼 포트로 들어가서

Router(config-if)#ip ospf network broadcast

Router8

Router(config)#router ospf 7

Router(config-router)#network 1.1.123.0 0.0.0.255 area 0

Router(config-router)#int s0/0/0.123 mul 

 //중계라우터이기에 서브로 들어가서 설정해 줘야함

Router(config-subif)#ip ospf network broadcast

2. 우선순위 부여

중계라우터에서 밑에 명령어 실행

Router(config-subif)#ip ospf priority 100

3. 모든 라우터 초기화

//모든 라우터에 명령어 입력해줘야한다.

Router(config-subif)#do clear ip ospf proc

Reset ALL OSPF processes? [no]: yes


 

 


'Network Security' 카테고리의 다른 글

RIP  (0) 2019.01.28
라우팅  (0) 2019.01.25
PPP인증  (0) 2019.01.24
NAT  (0) 2019.01.23
DHCP  (0) 2019.01.23

 

라우터 프로토콜 변경

 

1. 포트접속

 

2.원하는 프로토콜 선택

Router(config-if)#encapsulation [프로토콜]

 

[프로토콜]

PPP                //인증 가능

HDLC             //인증 x

frame-relay     //인증 x

 

 

 [PPP인증]

 

[CHAP인증]

 

Router3

1. Router(config)#host R1

2. R1(config)#username R2 password 1234   //상대측 이름

3. R1(config)#int s0/0/0

4. R1(config-if)#ppp authentication chap

Router4

1. Router(config)#host R2

2. R2(config)#username R1 password 1234  //상대측 이름

3. R2(config)#int s0/0/0

4. R2(config-if)#ppp authentication chap

 

[PAP인증]

 

Router3

1. R1(config)#username R2 password 1234

2. R1(config)#int s0/0/0

3. R1(config-if)#ppp authentication pap

4. R1(config-if)#ppp pap sent-username R1 password 1234

// 자신의 이름 과 패스워드

Router4

1. R2(config)#username R1 password 1234

2. R2(config)#int s0/0/0

3. R2(config-if)#ppp authentication pap

4. R2(config-if)#ppp pap sent-username R2 password 1234

// 자신의 이름 과 패스워드

 

 

 

'Network Security' 카테고리의 다른 글

라우팅  (0) 2019.01.25
frame-relay  (0) 2019.01.24
NAT  (0) 2019.01.23
DHCP  (0) 2019.01.23
서버를 이용한 인증  (0) 2019.01.22

 

NAT

 

- Dynamic과static으로 나뉜다.  //더이상 사용하지 않음.

- NAT 자체로는 주소절약X

- NAT 안에 있는 PAT가 주소절약에 쓰인다.

- 현재 PAT가 없으면 ip부족으로 인터넷을 사용할 수 없는 상황

- PAT -> 공인ip 1개로 사설ip을 다룬다.

- 사설ip와 공인ip가 만날 때 작동해야한다.

 

NAT 사용 이유

- IP주소 절약

- 보안성 강화 //방화벽의 역할을함.

 

 

Static NAT

 

Router(config)#ip nat inside source static 192.168.10.2 210.210.210.1

//192.168.10.2의 아이피가 210.210.210.1로 변환해서 통신해라 라는 뜻.

 

Router(config)#int fa0/0

Router(config-if)#ip nat inside 

 

Router(config-if)#int s0/0/0

Router(config-if)#ip nat outside

 

 

PC0에 ip 만을 static으로 설정해주었기에, PC0만 Router1과 통신이 가능하다.

 

PC0 //inside      Router1 //outside

또한 PC0 -> Router1은 가능하지만, Router1->PC0은 불가능하다.

 

NAT 확인방법

show ip nat translations

 

 

Dynamic NAT

1.[공인 IP 주소 pool]

Router(config)#ip nat pool test 210.210.210.1 210.210.210.254 netmask 255.255.255.0

//210.210.210.1 ~ 210.210.210.254 만큼 사용 가능.

 

2. [사설 IP 주소 pool]

Router(config)#access-list 10 permit 192.168.10.0 0.0.0.255

3. [공인 IP + 사설 IP주소 매핑]

Router(config)#ip nat inside source list 10 pool test 

//사설IP의 list 번호 10 과 공인 IP의 pool이름 test 로 매핑

4. inside와 outside 설정

각 역할에 맞는 포트에 들어가 ip nat inside/outside

 

overload      //PAT

1.[공인 IP 주소 pool]

Router(config)#ip nat pool test 210.210.210.1 210.210.210.1 netmask 255.255.255.0

2. [사설 IP 주소 pool]

Router(config)#access-list 10 permit 192.168.10.0 0.0.0.255

3. [공인 IP + 사설 IP주소 매핑]

Router(config)#ip nat inside source list 10 pool test overload

4. inside와 outside 설정

각 역할에 맞는 포트에 들어가 ip nat inside/outside

 

즉, PAT는 공인ip 1개로 사설ip를 다루게 되어 ip주소절약에 쓰인다.

'Network Security' 카테고리의 다른 글

frame-relay  (0) 2019.01.24
PPP인증  (0) 2019.01.24
DHCP  (0) 2019.01.23
서버를 이용한 인증  (0) 2019.01.22
스위치 루핑 구조  (0) 2019.01.22

DHCP 설정

- 호스트 쉽게 부여

- ip address 절약

 

 

 

excluded-address //배제

 

Router(config)#ip dhcp excluded-address 192.168.10.1

 // 192.168.10.1 배제

pool //풀장 생성

 

Router(config)#ip dhcp pool test

//test 라는 공간 생성

Router(dhcp-config)#default-router 192.168.10.1

//게이트웨이 설정

Router(dhcp-config)#network 192.168.10.0 255.255.255.0

//c클래스부여 ,할당한 대역

Router(dhcp-config)#dns-server 168.126.63.1

//dns 서버 부여

 

아래 사진과 같이 부여됨.

 

DHCP 서버를 이용한 방법

1. 서버 설정

Default Gateway //라우터 게이트웨이

설정을 다한 후, Save

 

 

2.라우터포트 서버와 연결된 포트가 아닌, 네트워크와 연결된 포트로 접속

Router(config-if)#ip helper-address 192.168.20.100

//서버 ip주소

 

 

서버를 이용한 DHCP 구성도

 

 

 

 

 

 

'Network Security' 카테고리의 다른 글

PPP인증  (0) 2019.01.24
NAT  (0) 2019.01.23
서버를 이용한 인증  (0) 2019.01.22
스위치 루핑 구조  (0) 2019.01.22
VTP  (0) 2019.01.22

 

서버를 이용한 인증

Router(config)#aaa new-model

Router(config)#aaa authentication login default group radius  //radius로 생성

Router(config)#radius-server host 192.168.10.100  //서버 아이피

Router(config)#radius-server key cisco   //키생성

Router(config)#line con 0  //콘솔접속

Router(config-line)#login authentication default  //인증으로 로그인

 

 

위의 설정을 라우터에서 다한 후, 서버에서 설정한다.

 

 

 Client Name : 아무거나줘도 됨

 Client IP : 라우터의 게이트웨이 주소

 Secret : 라우터에서 생성한 키

 ServerType : 라우터에서 설정한 타입.

 

Username : 콘솔에서 접속할 아이디

Password :  콘솔에서 접속할 비번

 

위의 그림과 같이 실행됨.

'Network Security' 카테고리의 다른 글

NAT  (0) 2019.01.23
DHCP  (0) 2019.01.23
스위치 루핑 구조  (0) 2019.01.22
VTP  (0) 2019.01.22
VLAN  (0) 2019.01.21

+ Recent posts